Website Emergency Maintenance
Scheduled for March 28, 2024 at 12:19 PM – 12:28 PM
Affects
Website
Under maintenance from 12:19 PM to 12:28 PM
Completed
March 28, 2024 at 12:28 PMCompleted
March 28, 2024 at 12:28 PMEmergency Maintenance was completed without any issues.
In progress
March 28, 2024 at 12:21 PMIn progress
March 28, 2024 at 12:21 PMMaintenance is now in progress.
Planned
March 28, 2024 at 12:19 PMPlanned
March 28, 2024 at 12:19 PMWe are carrying out emergency maintenance on our main website, the dashboard is not included.